Just joined? Please introduce yourself.
Classic Edge Designs, LLC Prime Custom Cars, LLC MadMooks
Results 1 to 6 of 6

Thread: Can you identify this module?

  1. #1
    Registered Member WagonCrazy's Avatar
    Join Date
    Mar 2012

    Member #:530
    Location
    Santa Clarita, CA
    Posts
    830

    Can you identify this module?

    I'm starting to get the wiring harness figured out on my LS1/T56 Nomad conversion. The harness and stock ECM was put together by the previous owner (7+ years ago) and I removed it and boxed it up when I bought it. The Nomad was never in running condition, so I have no idea if it was wired up right or wrong. So it's been many years now since it's seen the light of day. And I'm starting to examine every aspect of the harness as I determine the routing/installation plan.

    The owner wasn't clear if he ever had the ECM flashed, and mentioned he "worked around the VATS by the way he wired it".

    This little VAT-1 module is connected to 2 pins on the ECM PLUS a ground wire.

    IMG_3123.jpg IMG_3124.jpg

    There are no other markings on this module, indicating who makes it (a google search on VAT-1 doesn't yield anything obvious). The wiring schematics over at lstech.com and lt1swap.com don't mention this in their diagrams.

    So I'm thinking the Previous Owner did NOT get the whole VATS attributes deleted from the ECM, and this is a workaround... (remember this was probably 7 to 9 years ago when this whole LS conversion thing was still emerging).

    Green wire goes to RED Bank- Pin #30 "Fuel Enable Control"
    Red wire goes to BLUE Bank- Pin #8 "Throttle Position Sensor" (which makes no sense to me).
    Black wire goes to Ground

    I will send this ECM in for a re-flash anyway...because the new build attributes of the car are now different than where the former owner was going with it. And in reading a few websites of guys who do re-flash services, they all say they completely disable the VATS attributes anyway...so this little module may be unnecessary.

    Anyone else ever seen one of these modules? What do they do?
    1957 Nomad- LS1/T56 on C4 chassis- [URL=http://s78.photobucket.com/user/pcardey/library/57%20Chevy%20Nomad%20wagon[/URL]

    1959 Fleetside Apache 1/2 ton, shortbed, big window- [URL=http://s78.photobucket.com/user/pcardey/library/59%20Apached%20Fleetside%20Big%20Window%20Shortbed[/URL]

  2. #2
    Registered Member
    Join Date
    Mar 2012

    Member #:532
    Location
    Georgetown, Ky
    Posts
    153
    Quote Originally Posted by WagonCrazy View Post
    I'm starting to get the wiring harness figured out on my LS1/T56 Nomad conversion. The harness and stock ECM was put together by the previous owner (7+ years ago) and I removed it and boxed it up when I bought it. The Nomad was never in running condition, so I have no idea if it was wired up right or wrong. So it's been many years now since it's seen the light of day. And I'm starting to examine every aspect of the harness as I determine the routing/installation plan.

    The owner wasn't clear if he ever had the ECM flashed, and mentioned he "worked around the VATS by the way he wired it".

    This little VAT-1 module is connected to 2 pins on the ECM PLUS a ground wire.

    IMG_3123.jpg IMG_3124.jpg

    There are no other markings on this module, indicating who makes it (a google search on VAT-1 doesn't yield anything obvious). The wiring schematics over at lstech.com and lt1swap.com don't mention this in their diagrams.

    So I'm thinking the Previous Owner did NOT get the whole VATS attributes deleted from the ECM, and this is a workaround... (remember this was probably 7 to 9 years ago when this whole LS conversion thing was still emerging).

    Green wire goes to RED Bank- Pin #30 "Fuel Enable Control"
    Red wire goes to BLUE Bank- Pin #8 "Throttle Position Sensor" (which makes no sense to me).
    Black wire goes to Ground

    I will send this ECM in for a re-flash anyway...because the new build attributes of the car are now different than where the former owner was going with it. And in reading a few websites of guys who do re-flash services, they all say they completely disable the VATS attributes anyway...so this little module may be unnecessary.

    Anyone else ever seen one of these modules? What do they do?
    Painless and others sell those.I've never used them but from my understanding they're a work around for the VATs without reprogramming the ECM. I've always had to reprogram the ECM anyway so why use them? I think your headed down the right path by removing the ECM logic.

  3. #3
    Registered Member
    Join Date
    Apr 2012

    Member #:571
    Posts
    3,168
    Those modules used to be all over Ebay but I've no idea where that one came from. They are just a workaround to avoid the cost and hassle of having your ecm reflashed.

    As already suggested, if you are going to flash a new tune you can get rid of VATS when that's done.

  4. #4
    Registered Member WagonCrazy's Avatar
    Join Date
    Mar 2012

    Member #:530
    Location
    Santa Clarita, CA
    Posts
    830
    Thanks guys. I found a .pdf instruction document from Painless that describes the way these 3 wires are connected. Mine are connected in this manner.
    I will eliminate this module and get the VATS removed when the ECM is reflashed.
    Movin on....
    1957 Nomad- LS1/T56 on C4 chassis- [URL=http://s78.photobucket.com/user/pcardey/library/57%20Chevy%20Nomad%20wagon[/URL]

    1959 Fleetside Apache 1/2 ton, shortbed, big window- [URL=http://s78.photobucket.com/user/pcardey/library/59%20Apached%20Fleetside%20Big%20Window%20Shortbed[/URL]

  5. #5
    Registered Member WagonCrazy's Avatar
    Join Date
    Mar 2012

    Member #:530
    Location
    Santa Clarita, CA
    Posts
    830
    So I posted this issue in ls1tech.com in the pcm/ecm tuning section and 159 people have lurked with NO comments. ZERO. not even a F_CK off or anything.
    So much for a willing brain trust over there...guess I'll stick around here some.
    1957 Nomad- LS1/T56 on C4 chassis- [URL=http://s78.photobucket.com/user/pcardey/library/57%20Chevy%20Nomad%20wagon[/URL]

    1959 Fleetside Apache 1/2 ton, shortbed, big window- [URL=http://s78.photobucket.com/user/pcardey/library/59%20Apached%20Fleetside%20Big%20Window%20Shortbed[/URL]

  6. #6
    Registered Member WagonCrazy's Avatar
    Join Date
    Mar 2012

    Member #:530
    Location
    Santa Clarita, CA
    Posts
    830
    I definately did get the ECM reflashed (including removing the VATS functionality), and definately did eliminate this module.
    Still in wiring mode on the Nomad though, so not yet started or running (to confirm it all works as planned)
    But soon! (Dammit)
    1957 Nomad- LS1/T56 on C4 chassis- [URL=http://s78.photobucket.com/user/pcardey/library/57%20Chevy%20Nomad%20wagon[/URL]

    1959 Fleetside Apache 1/2 ton, shortbed, big window- [URL=http://s78.photobucket.com/user/pcardey/library/59%20Apached%20Fleetside%20Big%20Window%20Shortbed[/URL]

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •