Just joined? Please introduce yourself.
Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: TH350 removal from my '56 Nomad today

  1. #21
    Registered Member
    Join Date
    May 2012

    Member #:625
    Posts
    3,327
    duplicate

  2. #22
    Registered Member BamaNomad's Avatar
    Join Date
    Nov 2016

    Member #:3217
    Location
    Rocket City, USA (Huntsville, AL area)
    Posts
    3,428
    Quote Originally Posted by markm View Post
    Why do they make those tubes so small, I will not use one, my Th350 in my 56 had a 79 Z28 stick and my 700R4 has a 85 Caprice wagoon stick.
    I agree with you Mark... I'd never buy one (I don't think).. but my '56 Nomad had one in it when purchased...

    BelAir-o

    Using a small (tiny) funnel is the only way I've found to do it also, but the idea of adding 8-10 qts thru that thing is frustrating!
    Last edited by BamaNomad; 06-22-2022 at 05:37 AM.

  3. #23
    Registered Member Belair-o's Avatar
    Join Date
    Jun 2013

    Member #:1723
    Location
    Franktown, CO
    Posts
    493
    Gary,
    I don't use the adaptor - I use a decent sized funnel that has an opening that just fits in the Lokar tube. Every millimeter helps get the fluid in, which is why I skipped the adaptor.
    Regards, Doug

  4. #24
    Registered Member BamaNomad's Avatar
    Join Date
    Nov 2016

    Member #:3217
    Location
    Rocket City, USA (Huntsville, AL area)
    Posts
    3,428

    8 qts added this way

    It wasn't as bad as I feared, using the funnel with tube, jammed into the Lokar adapter with the funnel zip-tied to the battery box so I didn't have to hold it... The fluid Valvoline Dexron III / Mercon I had difficulty finding in local FLAPS so I ordered it in gallons. I poured about a quart at a time into the 'juice bottle' to make it easier to pour... took me less than 30 min, and in my garage with the AC on, it wasn't so bad...

    Funnel with tube adapter.jpg [ATTACH]12649[/ATTACH

    I was told by the trans shop to add 8 qts minimum before starting the engine, so I got it all in (although that last quart or so was very slow to seep down).. but then the engine wouldn't start...?? checked the battery .. it was good... scratched my head.. figured the transmission selector must need adjusting so I can get it into Park (or Neutral) ... so gotta adjust the transmission selector now! I hope that's all it is.

    How much fluid should it take? It has a small remote cooler, and a deeper Derale cooling pan...
    Will it be OK to add the remaining using Dexron VI (synthetic)???
    Attached Images Attached Images
    Last edited by BamaNomad; 06-22-2022 at 09:24 AM.

  5. #25
    Registered Member
    Join Date
    May 2012

    Member #:625
    Posts
    3,327
    I not only don't like the slow fill the billet look does not fit well with the 3x2s Vette valve covers etc.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •